We are experiencing unusually long app load times
Incident Report for Rachio
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 03:53 UTC
Update
We have found the issue and are investigating what the cause is.
Posted Jun 21, 2022 - 03:02 UTC
Update
We have our Engineering team online and are investigating this issue.
Posted Jun 21, 2022 - 01:45 UTC
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 01:40 UTC
This incident affected: iOS, Android, and API.